Sunday, July 21, 2013

Your account has been disabled error message when you try to sign in to Outlook Web App

Issue:

When user trying to access the mailbox in OWA they getting error message “"Your account has been disabled" 

Error Message: -


Additionally, if you click Show Details in the dialog box, you see stack trace results that resemble the following:

Request
Url: https://webmail.learnexchange.com:443/owa/
User host address: 192.168.1.1
User: Gengaiyan
EX Address: /o=mms/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=Gengaiyan
SMTP Address: Gengaiyan@learnexchange.com
OWA version: 14.2.318.3
Exception
Exception type: Microsoft.Exchange.Data.Storage.AccountDisabledException
Exception message: Cannot open mailbox /o=mms/ou=exchange administrative group (fydibohf23spdlt)/cn=recipients/cn=Gengaiyan.

Error Statement: -

This error message basically occurs due to Active Directory Replication delay, Wait for 15 minutes after above change.
If mailbox is not working after 15 minutes  then it’s something wrong on the mailbox, So take the below action to resolve the issue.

Resolution: -

1.   Disable the Mailbox

i)             In the console tree, navigate to Recipient Configuration > Mailbox.
ii)           In the result pane, select the mailbox that you want to disable.
iii)          In the action pane, under the name of the mailbox, click Disable.
iv)          A warning appears asking, Are you sure you want to disable 'mailbox name'? Click Yes to disable the mailbox.

2.   Clean the Mailbox database

Get-Mailboxdatabase –Identity “DB01” | Clean-Mailboxdatabase

3.   Reconnect the mailbox.

i)             In the console tree, navigate to Recipient Configuration > Disconnected Mailbox.
ii)           In the result pane, select the mailbox that you want to Connect.
iii)          In the action pane, under the name of the mailbox, click Connect.
iv)          Select match user and Click Browse and find the match user and connect. It will take some time to reflect in Mailbox Container.
v)            If mailbox does not appear after replication, Run Get-Mailboxdatabase | Clean-Mailboxdatabase.

Once Mailbox appeared in Mailbox Container, Try to access the mailbox in OWA and Outlook it will work.
Thanks
Keep Visit.